We kindly advise you to keep your browser up-to-date. We regularly test MyCourses with Safari, Firefox and Internet Explorer.

The current MyCourses version uses Moodle 3.9.

https://docs.moodle.org/dev/Moodle_3.9_release_notes#Browser_support